Slower response (Issue Checklist Free)
Incident Report for HeroCoders
Resolved
This incident has been resolved.
Posted Jun 01, 2020 - 19:06 BST
Investigating
Issue Checklist Free is responding slower than usual and we are currently looking into the issue.
Posted Jun 01, 2020 - 19:03 BST
This incident affected: Checklist (Issue Checklist Free).